Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

"Show Ignored Tests" issue
agiro
#1 Posted : Friday, April 21, 2017 9:47:36 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 4/7/2017(UTC)
Posts: 3
Location: Italy

Thanks: 2 times
I'm deselecting "Show Ignored Tests" but Ignored Tests are still visible on NCrunch window.
"Show Passing Tests" toggle works fine.
I'm using NCrunch 3.6.0.2 for Visual Studio 2017

show ignored tests

Thanks!
Alessandro
Remco
#2 Posted : Friday, April 21, 2017 10:11:20 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 4,639

Thanks: 606 times
Was thanked: 697 time(s) in 667 post(s)
Hi Alessandro,

Thanks for sharing this problem.

I'm aware of an issue right now where the filters seem to desynchronise sometimes when changing solutions. Did you swap solutions during the same VS session? Does the issue still exist for you after a restart?
agiro
#3 Posted : Friday, April 21, 2017 10:18:01 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 4/7/2017(UTC)
Posts: 3
Location: Italy

Thanks: 2 times
Hi Remco,

usually I'm using several VS instances, one per solution, but the issue is reproducible with a single VS session as well.
The issue still exists after a restart.

Thanks
Alessandro
Remco
#4 Posted : Friday, April 21, 2017 10:19:44 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 4,639

Thanks: 606 times
Was thanked: 697 time(s) in 667 post(s)
Does turning the filter on/off make any difference?

Are the tests 'pinned' to the Tests Window?
1 user thanked Remco for this useful post.
agiro on 4/21/2017(UTC)
agiro
#5 Posted : Friday, April 21, 2017 10:23:56 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 4/7/2017(UTC)
Posts: 3
Location: Italy

Thanks: 2 times
Turning the filter on/off doesn't make any difference but the issue is related to pinned tests.
Basically if a test is "pinned" it ignores the filter. Unpinning the tests it works perfectly. Thanks!

Remco
#6 Posted : Friday, April 21, 2017 10:28:58 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 4,639

Thanks: 606 times
Was thanked: 697 time(s) in 667 post(s)
agiro;10309 wrote:
Turning the filter on/off doesn't make any difference but the issue is related to pinned tests.
Basically if a test is "pinned" it ignores the filter. Unpinning the tests it works perfectly. Thanks!



Got it, thanks! This is by design. When a test is 'pinned', it is always visible regardless of the filters. The idea behind the pinning of tests was that in some situations it was useful to be able to see a test's results by selecting the test in a context menu (i.e. by right-clicking on one of the coverage markers). If the test was subject to filters, there was no way to show it in the Tests Window without turning all of the filters off.
1 user thanked Remco for this useful post.
agiro on 4/21/2017(UTC)
Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.034 seconds.