Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

NCrunch failing to build 4.6.1 project (VS2017)
twistedtwig
#1 Posted : Friday, September 08, 2017 2:42:07 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 9/8/2017(UTC)
Posts: 2
Location: United Kingdom

Was thanked: 1 time(s) in 1 post(s)
Hello,

I am using VS2017 Pro Version 15.3.3

I have Ncrunch 3.11.0.9.

I have not been able to run NCrunch on one of our projects at work. When I open the NCrunch Processing Queue window I can see the task build assembly with Status failure with the following output:

[15:08:50.2503-LocalBuildTask-35] ERROR (Internal): System.ArgumentException: An item with the same key has already been added.
at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer)
at nCrunch.Core.BuildManagement.BuildEnvironment.(BuildOutput )
at nCrunch.Core.BuildManagement.BuildEnvironment.Build(SnapshotComponent snapshotComponentToBuild, IList`1 referencedComponents, GridClientId gridClientId, IList`1 customEnvironmentVariables, IPlatformBuildExtender extender)
at nCrunch.Core.Processing.BuildTaskLogic.DoProcessTaskAndReturnSuccessFlag()
at nCrunch.Core.Processing.TaskLogic.ProcessTaskAndReturnSuccessFlag()
at nCrunch.Client.Processing.LocalProcessingTask.ProcessTaskAndReturnSuccessFlag()
at nCrunch.Client.Processing.ProcessingQueue..()

I am not sure how to go about fixing this issue, or if it is a bug in NCrunch how to give enough feedback to help fix it.

Any assistance would be very gratefully received.


Jon
Remco
#2 Posted : Saturday, September 09, 2017 12:49:11 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 4,864

Thanks: 648 times
Was thanked: 752 time(s) in 717 post(s)
twistedtwig
#3 Posted : Monday, September 11, 2017 8:46:57 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 9/8/2017(UTC)
Posts: 2
Location: United Kingdom

Was thanked: 1 time(s) in 1 post(s)
Hi,

Thank you for that, manually installing the 2017 zip worked great.

Jon
1 user thanked twistedtwig for this useful post.
Remco on 9/11/2017(UTC)
paulrogero
#4 Posted : Monday, October 02, 2017 1:39:00 AM(UTC)
Rank: Member

Groups: Registered
Joined: 6/4/2012(UTC)
Posts: 22

Was thanked: 3 time(s) in 3 post(s)
The download you posted fixed this issue for me as well in VS2017. Thanks!
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.041 seconds.