Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Filtered tests are stuck in 'Pending' status
ndeslandes
#1 Posted : Thursday, March 01, 2018 3:09:26 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 2/12/2014(UTC)
Posts: 5
Location: United Kingdom

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
Hi,

I want to filter out "LongRunning" tests from NCrunch execution. To get that behaviour, I defined a test category "LongRunning", and setup the shared test configuration to specify that only test that don't have this category should be run:
Categories

But when NCrunch runs, even though I can see the category has been recognised, the tests are still shown as pending:
Tests

They are also showing up as pending in the Test queue view.

How can I properly ignore these tests?

Cheers,

Nico
Remco
#2 Posted : Thursday, March 01, 2018 11:39:16 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,238

Thanks: 691 times
Was thanked: 843 time(s) in 803 post(s)
Hi Nico,

The 'Pending' status represents tests that haven't yet been executed. It's an assumption by NCrunch that a pending test will eventually be executed, though under your configuration this would not be possible (unless a grid node were connected without the configured constraint). So perhaps a better status description in this case would be 'Unexecuted'.

The 'Tests to execute on this machine' setting is usually used for distributed processing to control which servers are able to target specific groups of tests. For your purposes, it would probably be better to use the 'Tests to execute automatically' configuration setting instead, as I'm assuming that these tests can still be run under NCrunch manually. Tests that are excluded using this setting won't be queued for execution unless they are specifically targeted in the UI.

If the tests simply cannot be run by NCrunch at all and you don't want to see them, it's better to use the 'Ignored tests' feature in the Tests Window to hide them from your session.
1 user thanked Remco for this useful post.
ndeslandes on 3/7/2018(UTC)
ndeslandes
#3 Posted : Wednesday, March 07, 2018 9:24:40 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 2/12/2014(UTC)
Posts: 5
Location: United Kingdom

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
Right on! For some reason I didn't even notice the "Tests to execute automatically" setting.
Your suggestion is exactly what I needed.
The tests are still marked as "Pending", but I can live with that. At least the global state now completes (ie the Stop button is grayed out, and the notification area in the status bar is happy).

Thanks Remco!
1 user thanked ndeslandes for this useful post.
Remco on 3/7/2018(UTC)
Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.026 seconds.