Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Problems with First Build
razorkai
#1 Posted : Friday, June 14, 2013 9:02:31 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 6/13/2013(UTC)
Posts: 5

Was thanked: 2 time(s) in 1 post(s)
Hi again

I'm getting the following error for one of my test projects.

NCrunch: If you are experiencing problems in getting this project to build, have a look at http://www.ncrunch.net/d..._project-build-issues#0
..\..\..\..\..\..\..\..\..\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\TeamTest\Microsoft.TeamTest.targets (14)#1: Could not load file or assembly 'AssemblyName, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

I've looked at the suggested link and it hasn't helped me. The file it can't find is referenced in the normal way so I don't know what is wrong.

Any ideas?

Thanks
Remco
#2 Posted : Friday, June 14, 2013 12:09:50 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,234

Thanks: 691 times
Was thanked: 843 time(s) in 803 post(s)
Hi,

Are you by chance making use of MSTest private method accessors? If so, you'll need to turn on the Copy reference assemblies to workspace setting for ALL projects involved. The private method accessors use a specialised build step that expects referenced assemblies to exist adjacent to test assemblies, which isn't the case for the default configuration in NCrunch. Because this setting has a large impact on performance, I recommend avoiding private method accessors where possible.

Cheers,

Remco
razorkai
#3 Posted : Friday, June 14, 2013 1:07:04 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 6/13/2013(UTC)
Posts: 5

Was thanked: 2 time(s) in 1 post(s)
Hi

There is an accessor class created by Visual Studio, but I am not using it. I tried deleting it and it now builds fine in NCrunch.
Before deleting the accessor I tried the copy assemblies to workspaces setting but it made no difference.

Cheers
razorkai
#4 Posted : Friday, June 14, 2013 1:23:07 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 6/13/2013(UTC)
Posts: 5

Was thanked: 2 time(s) in 1 post(s)
I still have one project failing to build. It says the following

NCrunch: If you are experiencing problems in getting this project to build, have a look at http://www.ncrunch.net/d..._project-build-issues#0
..\..\..\..\..\..\..\..\..\..\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets (3416)#1: Could not write lines to file "obj\Debug\ProjectName.vbproj.FileListAbsolute.txt". The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.
..\..\..\..\..\..\..\..\..\..\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets (3658)#2: Could not write lines to file "obj\Debug\ProjectName.vbproj.FileListAbsolute.txt". The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.

We do have quite deeply nested folder structures, and I have already adjusted the workspace folder to be in the root of my drive. I'm not sure what to to do here either.
Remco
#5 Posted : Saturday, June 15, 2013 2:22:20 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,234

Thanks: 691 times
Was thanked: 843 time(s) in 803 post(s)
Generally placing the workspace root at the base of the disk would be enough to solve this problem. There is sadly little more that can be done to solve this from the side of NCrunch configuration, as the directory structures used by NCrunch are required to properly separate your projects during workspacing and are already sized as small as NCrunch can make them. To get this to work, you'll need to make some changes to the solution itself. A few useful tricks are:

- Try changing the DEBUG build configuration on projects to avoid placing the binaries in a bin\Debug or obj\Debug directory - instead try for just 'bin' or 'obj', as this can shave a few characters off
- Look out for references reaching from a project's base directory upwards (i.e. ..\..\..\) into the solution structure. NCrunch needs to space these out within its workspaces, so they can add many characters to the overall path length. If you can reduce or remove these references (perhaps copy them upwards into the project directory?) for problematic projects, this may do the trick
- When setting the workspace base path to the root of your drive, try doing so using as small a name as possible for the workspace directory, something like just 'W' would save a few characters
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.045 seconds.