Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

NCrunch 3.6.0.2 requires your project to use .NET 4.6.2
fourpastmidnight
#1 Posted : Tuesday, March 21, 2017 6:29:28 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 3/21/2017(UTC)
Posts: 7
Location: United States of America

Thanks: 1 times
Was thanked: 3 time(s) in 2 post(s)
This is terrible. It's not always easy for customers to just "update the version of .NET" they're product is compiling against.

NCrunch should be able to use any supported version of the .NET Framework as a "continuous test runner" tool.

I had to uninstall this version and re-install 3.5.x in order to continue using this product with my current project, and deal with the annoying pop-up everytime I start Visual Studio. :(

Regards,

~ fourpastmidnight
Remco
#2 Posted : Tuesday, March 21, 2017 11:20:09 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,410

Thanks: 708 times
Was thanked: 881 time(s) in 837 post(s)
Hi,

This is caused by a regression in v3.6 where the engine is not detecting the correct version of .NET installed on the system.

Detecting the newer versions of .NET is often difficult because these frameworks are usually released from Microsoft without any guidance on how to accurately detect them. The guidance usually comes later down the line (thankfully, it's now here).

NCrunch doesn't require you to use v4.6.2 for your projects. The error you're describing is for the engine process. NCrunch needs to use a specific version of .NET to host the engine process, which should ideally be aligned with the .NET version used by Visual Studio. When it initialises the engine, NCrunch tries to identify whether v4.6.2 is installed. If it is, the engine will be loaded under v4.6.2 instead of v4.6.1.

There is no need for you to change the version of .NET you are compiling against. You should never need to do this for NCrunch. The problem you're facing is that the tool has a flawed dependency on v4.6.2. As long as you have v4.6.2 installed, all should be well. This will be fixed in v3.7.
fourpastmidnight
#3 Posted : Tuesday, March 21, 2017 11:53:56 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 3/21/2017(UTC)
Posts: 7
Location: United States of America

Thanks: 1 times
Was thanked: 3 time(s) in 2 post(s)
Thanks for the explanation and quick response. I really appreciate it. I love the tool, too; so, thanks for all of your hard work! I'm surprised I don't have 4.6.2 installed, I thought I had that on my dev machine. Anyway, I look forward to the next release. Thanks again!!
1 user thanked fourpastmidnight for this useful post.
Remco on 3/22/2017(UTC)
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.037 seconds.