Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Build errors from SourceLink put NCrunch into weird state
kierenj
#1 Posted : Friday, June 1, 2018 7:31:59 AM(UTC)
Rank: Member

Groups: Registered
Joined: 8/25/2016(UTC)
Posts: 14
Location: United Kingdom

Thanks: 3 times
Was thanked: 1 time(s) in 1 post(s)
I have a .NET Core solution (targetting a few platforms) and tried applying SourceLink to it, by adding the following to all the csprojs:
Quote:

<PropertyGroup>
<TargetFramework>netcoreapp2.1</TargetFramework>

<!-- Optional: Declare that the Repository URL can be published to NuSpec -->
<PublishRepositoryUrl>true</PublishRepositoryUrl>

<!-- Optional: Embed source files that are not tracked by the source control manager to the PDB -->
<EmbedUntrackedSources>true</EmbedUntrackedSources>

<!-- Optional: Include PDB in the built .nupkg -->
<AllowedOutputExtensionsInPackageBuildOutputFolder>$(AllowedOutputExtensionsInPackageBuildOutputFolder);.pdb</AllowedOutputExtensionsInPackageBuildOutputFolder>
</PropertyGroup>
<ItemGroup>
<PackageReference Include="Microsoft.SourceLink.GitHub" Version="1.0.0-beta-62925-02" PrivateAssets="All"/>
</ItemGroup>

For the net461, netstandard2.0 targets NCrunch reported a build error (from the SourceLink .targets file I guess) that it couldn't work out where the git repo was.

That's understandable and maybe something to work around but kind of not NCrunch's fault.

However for the (much more simply-targetting) projects, they failed without error message, and NCrunch didn't stop the whole build/discovery process "properly".

Quick screen capture:
https://kierenj.tinytake.../sf/MjY0NzAzMV83OTUwMDAw
Remco
#2 Posted : Friday, June 1, 2018 9:43:26 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,328

Thanks: 700 times
Was thanked: 866 time(s) in 824 post(s)
Hi, thanks for sharing this problem.

Is it possible that the projects are simply not being built because they rely on one of the other projects with a build failure? (Sorry I can't establish the dependency chain in the screen capture).
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.019 seconds.