Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Problem: no exceptions seen, no X symbols with Nunit
HannesK
#1 Posted : Sunday, February 5, 2012 12:28:35 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 2/5/2012(UTC)
Posts: 3

Was thanked: 1 time(s) in 1 post(s)
I didn't look too deep into this yet, but as of NCrunch 1.37b I don't see red cross symbols anymore. Also "Show Exception Details" doesn't work. But I still see the failing tests and tests covered on this line, and the exception details in the NCrunch tests window.

EDIT: just found out submitting a bug through ncrunch gives you more info.. sorry, how emberassing ^^ filed the bug, I'm keeping this here for others reference..

I'm using newest Nunit version from nuget.
VS is 2010, I installed it after VS 2011 Dev Preview.
So Installation went:
VS 2011 Dev Preview.
NCrunch for Dev 2011

VS 2010
VS 2010 SP1
VS 2010 SP1 Updates from Windows Update
NCrunch for VS 2010

everything on Windows7 64Bit, I have a bunch of Addons (Resharper 6.1.1 EAP, some extensions, Telerik JustMock) installed, deinstalled JustMock, suspended Resharper, disabled all Extensions (e.g. PostSharp), still have the issue:
simpleTests
Code
TestResults
Remco
#2 Posted : Sunday, February 5, 2012 7:55:27 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 7,045

Thanks: 941 times
Was thanked: 1265 time(s) in 1177 post(s)
Hi - thanks for reporting this problem.

It looks as though NCrunch isn't taking into account the localisation of your stack traces. Could you let me know anything more details about your current locality/culture? Do you have the culture set globally (i.e. in your O/S) or is it just within the tests you're executing?


Cheers,

Remco
HannesK
#3 Posted : Sunday, February 5, 2012 4:44:51 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 2/5/2012(UTC)
Posts: 3

Was thanked: 1 time(s) in 1 post(s)
I don't have set any culture in code (it's basically what you saw in the screenshots anyway). That was just a small testproject to play around with Ncrunch.
My OS is running with german localization. I also looked into every file via AstroGrep, all i found was culture=neutral and [assembly: AssemblyCulture("")]. So no fancy stuff (beside the german OS) localization-wise.

Thanks for looking into that, awesome tool!
Hannes

Edit: here's a screenshot from a debug session:
cultures
Remco
#4 Posted : Sunday, February 5, 2012 9:23:17 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 7,045

Thanks: 941 times
Was thanked: 1265 time(s) in 1177 post(s)
Thanks! I see a fix that needs to be applied here. I'll see what I can do about getting it into the next version. If you're able to set your tests to run with an EN culture, it should pick up the stack traces correctly until I can fix the issue - though I'm not sure if this will cause other problems for you.
HannesK
#5 Posted : Tuesday, February 7, 2012 1:50:18 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 2/5/2012(UTC)
Posts: 3

Was thanked: 1 time(s) in 1 post(s)
Thanks a lot! I will use english localization in my OS (I could swear I used that before and it worked, I guess something changed in ncrunch), english is not a problem for me.
1 user thanked HannesK for this useful post.
Remco on 2/7/2012(UTC)
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.037 seconds.
Trial NCrunch
Take NCrunch for a spin
Do your fingers a favour and supercharge your testing workflow
Free Download