Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

"New engine mode" not focusing new engine mode
GreenMoose
#1 Posted : Thursday, April 11, 2019 11:10:53 AM(UTC)
Rank: Advanced Member

Groups: Registered
Joined: 6/17/2012(UTC)
Posts: 457

Thanks: 124 times
Was thanked: 57 time(s) in 55 post(s)
[v3.24.0.5]/vstudio2017

(bit me again so I decided to write post). When I create a new engine mode (which I rarely do) I almost always starts to write the engine mode name on the exiting one, instead of the new one, and realizing it after a while I cancel the dialog and redo it.
I see no reason why one would create a new engine mode without actually editing something in it so I would vote for focusing the new engine mode in UI so maybe this is a "bug"?

A related even more minor issue: The NCrunch dialog windows do not close on Escape key (only Cancel button), compare with e.g. Tools->Options window in vstudio

(Related wish-list item: copy engine mode :P)

Thanks.
Remco
#2 Posted : Thursday, April 11, 2019 11:51:54 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,788

Thanks: 748 times
Was thanked: 961 time(s) in 916 post(s)
I've just now committed a code change to automatically select a new engine mode after it has been created in the UI. The UX really feels much better now. This will be included in the next build that goes out the door.
1 user thanked Remco for this useful post.
GreenMoose on 4/12/2019(UTC)
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.023 seconds.