Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Content files in dependent project not being copied to output
metcalfam
#1 Posted : Tuesday, April 23, 2019 9:57:33 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 9/29/2014(UTC)
Posts: 1
Location: United Kingdom

I have a failing test in a test project which references another project which has a content file in Template/SMS.txt.

When I delete the bin and obj folders in the test project then rebuilt it in VS the file exists as expected under the Template folder in the test project's bin path and the test passes using the built in MS test runner and the ReSharper test runner.

When I run the test with NCrunch, it fails. When I look at the NCrunch output dir (using the "Browse to workspace" method outlined here: https://www.ncrunch.net/...licit-file-dependencies) I don't see the Template folder.

I've tried using the "Additional Files To Include" configuration and also creating a "Link" in VS to the file under a Template folder local to the test project, still no luck.

Can anyone supply any guidance?
Remco
#2 Posted : Wednesday, April 24, 2019 12:31:30 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,722

Thanks: 744 times
Was thanked: 950 time(s) in 905 post(s)
Hi, thanks for posting!

This is caused by NCrunch's project atomicity constraints. It's a common problem that is fairly well documented and there are solutions available.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.025 seconds.