Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Extreme delays in build when post-build event included
anortham
#1 Posted : Monday, August 26, 2019 9:34:16 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 8/26/2019(UTC)
Posts: 2
Location: United States of America

Was thanked: 1 time(s) in 1 post(s)
I have a post build event that runs the TypeGen.Cli and this results in extreme delays and high cpu usage even though ncrunch is set to ignore post build events. Has anyone seen a similar issue?
Remco
#2 Posted : Tuesday, August 27, 2019 12:55:51 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,759

Thanks: 745 times
Was thanked: 956 time(s) in 911 post(s)
Hi, thanks for posting.

How is this post build event specified in your project file? Is this using a build property or a custom build target? Note that NCrunch will only suppress the properties - the custom build targets must have conditions applied to them if you want them suppressed (example).
anortham
#3 Posted : Tuesday, August 27, 2019 12:47:24 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 8/26/2019(UTC)
Posts: 2
Location: United States of America

Was thanked: 1 time(s) in 1 post(s)
It's a target, I'll apply the condition and test. Thanks.

UPDATE: this has fixed my issue. Thanks for the help.
1 user thanked anortham for this useful post.
Remco on 8/28/2019(UTC)
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.026 seconds.