Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Error when submitting via the website's contact form
rwv37
#1 Posted : Sunday, September 1, 2019 12:22:46 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 9/1/2019(UTC)
Posts: 3
Location: United States of America

When I try to submit a message via the website's contact form, I get the following error:

Sorry, but the following occurred while attempting to send your message: There was an error in the callback. 88|/wEWBwLK9+KFBALY16/xAwLA/JLXCQKYsvqpBAKN77GYBgKqxdKBCALvyYCVC0MOttvpqvY6TXviPOc5VvNpMu

I tried several times. I'm not sure if it's always that "88|/wEWB blah blah blah" stuff, but it's always that same sort of message.
Remco
#2 Posted : Sunday, September 1, 2019 11:23:20 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,818

Thanks: 752 times
Was thanked: 972 time(s) in 926 post(s)
Thanks for letting me know about this! Can you confirm which of these two forms you used? Also, which browser are you running on?

https://www.ncrunch.net/Support/Contact
https://blog.ncrunch.net/contact.aspx
rwv37
#3 Posted : Monday, September 2, 2019 5:19:05 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 9/1/2019(UTC)
Posts: 3
Location: United States of America

Remco;13805 wrote:
Thanks for letting me know about this! Can you confirm which of these two forms you used? Also, which browser are you running on?

https://www.ncrunch.net/Support/Contact
https://blog.ncrunch.net/contact.aspx


I don't know 100% for sure, but almost certainly https://www.ncrunch.net/Support/Contact. I know for sure that I followed the "Contact Us" link from https://www.ncrunch.net/support, which (at least currently) leads to that one.

I'm using Firefox 68.0.2, which is up-to-date. Possibly it's due to some junk-blocking extension I have installed? I'm mostly just using default blocking lists. I have just checked what all the extensions are blocking on that page, and it's the following two:

  • analytics.ncrunch.net (blocked by uBlock Origin - I guess because of "analytics"?)
  • Piwik (blocked by Ghostery - says it's a "tracker")


I have other junk-blocking extensions too, but none of them are blocking anything on that page.
Remco
#4 Posted : Tuesday, September 3, 2019 12:48:36 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,818

Thanks: 752 times
Was thanked: 972 time(s) in 926 post(s)
Thanks for these details. Can you confirm whether the error is still happening for you and whether it seems to be content specific? I cannot seem to find a way to recreate this problem.
rwv37
#5 Posted : Tuesday, September 3, 2019 1:38:28 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 9/1/2019(UTC)
Posts: 3
Location: United States of America

Remco;13813 wrote:
Thanks for these details. Can you confirm whether the error is still happening for you and whether it seems to be content specific? I cannot seem to find a way to recreate this problem.


I just tried again, and it worked fine. A few things, though:

1. I rebooted in between when it was not working and this time that it worked (for unrelated reasons - Windows Update was demanding it). So it might just have been some wacky state that my browser got itself into, or something like that.
2. When it was not working, it wasn't content-specific. At least not insofar as the main body of the form - I got the same error having typed at least two different messages.
3. Did the form change? I don't remember having needed to log in to use it before (which I did just now), and I'm pretty sure one of the fields was for my email address (which isn't there now).
Remco
#6 Posted : Tuesday, September 3, 2019 3:45:26 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,818

Thanks: 752 times
Was thanked: 972 time(s) in 926 post(s)
Yes, it looks like it worked correctly (I received the message).

I've just done a code review of both contact forms, and judging by the error you received, it actually came from this form: https://blog.ncrunch.net/contact.aspx

The above form is quite old and I'm less familiar with its internals. I wasn't able to produce a problem with it so I suspect the issue may be state or content dependent. Maybe give it a try to see if you can break it again?
Remco
#7 Posted : Tuesday, September 3, 2019 3:46:25 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 5,818

Thanks: 752 times
Was thanked: 972 time(s) in 926 post(s)
Scratch that, I've figured it out. The form will fail if you aren't logged into the system.

Thanks for your help on this.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.046 seconds.