Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Type or namespace does not exist when Instrumentation Mode is Optimized and using Shared Project
pabanc
#1 Posted : Monday, February 10, 2020 6:17:43 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 4/5/2019(UTC)
Posts: 1

NCrunch Version: 4.3.0.13
Visual Studio 2017 (15.9.11)

Solution contains a Shared Project (.shproj)

I've tried: (1) "Additional files to include" set to *.* in the shared project folder; and (2) Implicit project dependencies set to the shared project. Neither option has worked.

The Test Project will not build due to, for example: The type or namespace name 'x_namespace' does not exist in the namespace 'MySolution.Shared'

Variations of the above error occur for each reference to the shared project.

I have no problems when Instrumentation Mode is set to Legacy.
Remco
#2 Posted : Monday, February 10, 2020 10:24:13 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,117

Thanks: 794 times
Was thanked: 1043 time(s) in 993 post(s)
Hi, thanks for sharing this issue.

Shared projects essentially get rolled into the same assemblies once the compiler is done with them, so probably there is a code structure involved here that the compiler is creating that the new optimised mode just doesn't know how to handle.

Is there any chance you can isolate this problem with a sample solution that you can share with me? If I can reproduce it here, I should hopefully be able to promptly fix it. You can upload code in ZIP form through the contact form.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.026 seconds.