Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

running(first time run)
melnikd
#1 Posted : Monday, September 13, 2021 12:57:07 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2015(UTC)
Posts: 7
Location: United States of America

Hello,

I am using VS2019 16.11.2 , project - .NET Core 5
NCrunch V - 4.9.0.8

Most of the projects, in the solution, show "running(first time run)", circle icon. The solution has a mix of XUnit and MSTest tests. XUnit project execute tests fine, but all MSTests have problems
Remco
#2 Posted : Tuesday, September 14, 2021 12:04:46 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,399

Thanks: 835 times
Was thanked: 1116 time(s) in 1056 post(s)
Thanks for sharing this. Are you able to submit a bug report after you've had this happen to you? I'm hopeful the log file will contain some useful information.
melnikd
#3 Posted : Tuesday, September 14, 2021 12:32:43 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2015(UTC)
Posts: 7
Location: United States of America

Sure, if you tell me where to go to collect the logs
Remco
#4 Posted : Tuesday, September 14, 2021 1:41:04 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,399

Thanks: 835 times
Was thanked: 1116 time(s) in 1056 post(s)
melnikd;15634 wrote:
Sure, if you tell me where to go to collect the logs


Click on the 'NCrunch' menu then choose the 'Submit bug report' option.
melnikd
#5 Posted : Tuesday, September 14, 2021 3:46:24 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2015(UTC)
Posts: 7
Location: United States of America

Submitted a bug report
Remco
#6 Posted : Wednesday, September 15, 2021 12:49:20 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,399

Thanks: 835 times
Was thanked: 1116 time(s) in 1056 post(s)
Thanks for the report! Here is the error:
System.BadImageFormatException: Could not load file or assembly 'file:///C:\Users\melnikd\AppData\Local\NCrunch\29592\10\<AssemblyPath>.Tests.dll' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

(<AssemblyPath> is the name of your Tests assembly).

Can you confirm which version of .NET you are targeting with your test project? You mentioned that you have xunit and NUnit tests in this solution that work OK - are these inside the same project? Do they target the same version of .NET?

Could we try you on the newer version of NCrunch (v4.9) to see if this solves the problem?
melnikd
#7 Posted : Wednesday, September 15, 2021 4:31:47 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2015(UTC)
Posts: 7
Location: United States of America

The XUnit tests is a separate Test Project. They target the same version of .NET 5.0

I can try NCrunch v4.9

Remco
#8 Posted : Thursday, September 16, 2021 12:47:48 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,399

Thanks: 835 times
Was thanked: 1116 time(s) in 1056 post(s)
melnikd;15640 wrote:

I can try NCrunch v4.9


My apologies. I've just re-read your original post and it looks like you're already on the latest version.

I'm having difficulty reproducing this on my side. Under .NET 5.0, MSTest seems to work normally in my environment. Are you able to produce a self-contained sample project that can produce this problem? And if so, would you be able to share it with me? You can upload samples as attachments through the NCrunch contact form.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.230 seconds.
Trial NCrunch
Take NCrunch for a spin
Do your fingers a favour and supercharge your testing workflow
Free Download