Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Problems with Visual Studio 2022 (another thread)
9swampy
#1 Posted : Monday, August 29, 2022 11:30:33 PM(UTC)
Rank: Member

Groups: Registered
Joined: 8/8/2016(UTC)
Posts: 13
Location: United Kingdom

Noting in the title I've checked the other 2022 thread. We're on latest release.

Repeatedly VS2022 nCrunch just dies. On multiple machines, completely different setups (on-Company and off-Company) doing completely different slns (Company and not-Company).
VS Clean doesn't fix.
Dumping the _NCrunch folder doesn't fix.
Restart nCrunch doesn't fix (within VS)
Restart VS sometimes works, often doesn't...

but...

Exit VS, full TortoiseGit clean, -fx -d restart and re-enable nCrunch works.

So I've got a workable environment but it's a serious pita. Any advice/further info you'd like me to collect/report?
Remco
#2 Posted : Monday, August 29, 2022 11:33:39 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,636

Thanks: 873 times
Was thanked: 1184 time(s) in 1104 post(s)
Hi, thanks for sharing this.

What happens to NCrunch when it dies? Does it just stop working? Is there an error of any kind?

If you can submit an NCrunch bug report after this happens, I can run through the logs and try to work out what's going on.
9swampy
#3 Posted : Tuesday, August 30, 2022 10:45:07 PM(UTC)
Rank: Member

Groups: Registered
Joined: 8/8/2016(UTC)
Posts: 13
Location: United Kingdom

Hi Remco,

I've replied by email with a log attached.

Didn't get the context-menu-Submit-Bug-Report before I'd got VS working again, will do next time. Hopefully something useful in the logs in the meantime.
9swampy
#4 Posted : Friday, September 2, 2022 9:58:36 AM(UTC)
Rank: Member

Groups: Registered
Joined: 8/8/2016(UTC)
Posts: 13
Location: United Kingdom

VS 17.3.3 still same. Submitted Bug Report.
Remco
#5 Posted : Friday, September 2, 2022 1:15:28 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,636

Thanks: 873 times
Was thanked: 1184 time(s) in 1104 post(s)
Thanks for sending through the bug report.

The version of NCrunch you're running is quite old. Could you try updating to 4.14 and let me know if this solves the issue?
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.032 seconds.
Trial NCrunch
Take NCrunch for a spin
Do your fingers a favour and supercharge your testing workflow
Free Download