Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

NCrunch gets removed after VS 2010 Restarts
motowilliams
#1 Posted : Friday, October 14, 2011 3:29:28 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2011(UTC)
Posts: 4
Location: Missoula, MT, USA

After it is initially installed, without Visual Studio running, NCrunch is working fine with it's menu item on the toolbar. I can run it all day as long as I don't restart Visual Studio. Then is just disappears. If I rerun the MSI is registers as already installs and prompts with a Repair/Uninstall option. Selecting the Repair option beings NCrunch back to Visual Studio, again as long as it is not restarted.

Here is a link to my dropbox share, is has a before and after for the VS Info (from the About VS dialog), Devenv.exe /log, and ProcMon (SysInternals) with a filter for Remco.
http://dl.dropbox.com/u/89344/NCrunchLogs.zip

The Remco Software folder just disappears from the C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\ folder

This is a brand new machine with clean installs on everything and I don't have any issues with is.

Any ideas?
Eric
Remco
#2 Posted : Friday, October 14, 2011 5:22:28 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,138

Thanks: 795 times
Was thanked: 1050 time(s) in 1000 post(s)
Hi Eric,

Thanks for posting! This is a really weird problem. There isn't any code in NCrunch that would cause it to remove itself from the system (short of running the uninstaller, and from the behaviour you've described I don't think that's likely to be the case).

Are you running a virus scanner or any kind of software that might interfere with new installs?

Also .. would you be able to copy/paste the contents of your NCrunch configuration file? You can find this in (user)\AppData\Roaming\NCrunch\globalconfig.ncrunch.xml

Do you by chance have VS2008 installed on this machine? I'd be interested in knowing whether this exhibits similar behaviour ...
motowilliams
#3 Posted : Friday, October 14, 2011 6:37:38 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2011(UTC)
Posts: 4
Location: Missoula, MT, USA

The only virus/malware programs I'm running is Microsoft Security Essentials and unfortunately I don't have Visual Studio 2008 installed or available to me.

Here are the contents of my file globalconfig.crunch.xml
Quote:
<GlobalConfiguration>
<SystemConfigured>true</SystemConfigured>
<WorkspaceBasePath></WorkspaceBasePath>
<ProcessPoolSize>4</ProcessPoolSize>
<MaxNumberOfProcessingThreads>1</MaxNumberOfProcessingThreads>
<LogVerbosity>Summary</LogVerbosity>
<LogToOutputWindow>false</LogToOutputWindow>
<CPUCoresAssignedToVisualStudio>4,5,6,7</CPUCoresAssignedToVisualStudio>
<CPUCoresAssignedToNCrunch>0,1,2,3</CPUCoresAssignedToNCrunch>
<MarkerColorNoCoverage>-16777216</MarkerColorNoCoverage>
<MarkerColorPassingCoverage>-16744448</MarkerColorPassingCoverage>
<MarkerColorFailingCoverage>-65536</MarkerColorFailingCoverage>
</GlobalConfiguration>
motowilliams
#4 Posted : Friday, October 14, 2011 8:45:15 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2011(UTC)
Posts: 4
Location: Missoula, MT, USA

Maybe it is a conflict with ReSharper? This behavior also happens on my laptop.
Remco
#5 Posted : Saturday, October 15, 2011 10:07:31 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,138

Thanks: 795 times
Was thanked: 1050 time(s) in 1000 post(s)
I don't think that ReSharper would do this ... otherwise this forum would be exploding at the moment :) (Unless you have a very interesting development build of it).

Something interesting we could try is to lock the NCrunch install directory in such a way as to bug out whatever is trying to delete it. Try changing the security attributes of the 'Remco Software' directory so that it can't be modified or deleted by anyone other than the Administrator account. You could also try setting the read-only flag.

I think that this will either surface the offender (as an exception of some kind), or it will keep the installed content around and we will end up with a stickyplaster on the problem :)
motowilliams
#6 Posted : Monday, October 17, 2011 11:52:16 PM(UTC)
Rank: Newbie

Groups: Registered
Joined: 10/14/2011(UTC)
Posts: 4
Location: Missoula, MT, USA

Turns out the uninstalling the VS extension ExtensionSync solved the issue for me. It must have been misconfigured but at any rate I no longer needed it and I'm NCrunch'ing again!

Sorry for the wild goose chase and hopefully this will help others if they run into this issue and have some extension sync going on.

-Eric
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.043 seconds.