Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages<12
NCrunch 4 - Instrumentation Mode - Optimized - Project fails to build
Remco
#21 Posted : Wednesday, April 8, 2020 12:23:19 AM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,201

Thanks: 807 times
Was thanked: 1065 time(s) in 1012 post(s)
mkoertgen;14586 wrote:
Sorry for the typo, my bad. It's definitive the latest NCrunch 4.3.0.13


Thanks for confirming. The problem is being triggered by something unexpected in the CIL structure of the assembly. Are you able to reproduce this issue using a sample project that you can share with me?
mkoertgen
#22 Posted : Wednesday, April 8, 2020 10:06:42 AM(UTC)
Rank: Newbie

Groups: Registered
Joined: 7/16/2016(UTC)
Posts: 5
Location: Germany

Thanks: 1 times
Hi Remco,

I tried to extract parts of the respective code pieces but was not able to reproduce the issue on the extracted code, i.e. NCrunch works like a charm on the simplified version.

I can say so much that it is about a pretty intricate code-part which heavily involves Prism, Mef-containers, timers, resources, DelegateCommands, etc. (net48).
Personally, i would suggest to refactor and put this issue aside instead.

Thanks, Marcel.
Remco
#23 Posted : Wednesday, April 8, 2020 11:42:33 PM(UTC)
Rank: NCrunch Developer

Groups: Administrators
Joined: 4/16/2011(UTC)
Posts: 6,201

Thanks: 807 times
Was thanked: 1065 time(s) in 1012 post(s)
Thanks Marcel. Sorry that you got hit with this one. Please do let me know if you find a way to reproduce the problem in a way you can share with me.
Users browsing this topic
Guest
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.067 seconds.